Project

General

Profile

Wiki » History » Version 86

« Previous - Version 86/94 (diff) - Next » - Current version
Guillaume Babin, 03/07/2013 06:13 PM


Editeur Lustre

Installation de l'éditeur

Prérequis

  1. Installer ObeoDesigner (http://www.obeodesigner.com/download)
  2. Installer le plug-in Xtext sous ObeoDesigner (http://www.eclipse.org/Xtext/download.html)

[Méthode 1] Installation en tant que plug-in Eclipse à partir d'une archive déjà compilée

  1. Récupérer la dernière release sur https://cavale.enseeiht.fr/redmine/projects/lustreeditor/files
  2. Sous ObeoDesigner, Help > Install new software > Add > Archive
  3. Sélectionner l'archive téléchargée
  4. Valider > Ok
  5. Sélectionner le Lustre Editor, installer.
  6. Redémarrer ObeoDesigner, l'éditeur Lustre est maintenant utilisable !

[Méthode 2] Installation en tant que plug-in Eclipse en compilant à partir des sources

  1. Installer maven (version 3 ou supérieure) (sudo apt-get install maven sous Ubuntu)
    (configuration proxy : https://maven.apache.org/guides/mini/guide-proxies.html)
  2. Récupérer le projet lustre-parent du dépot (svn co https://cavale.enseeiht.fr/svn/lustreeditor)
  3. Se placer dans <path>/lustreeditor/trunk/lustre-parent/
  4. Exécuter mvn clean verify, attendre...
    [mvn -U clean verify peut régler des erreurs du type "Failure to find ....... was cached in the local repository......"]
  5. Sous ObeoDesigner, Help > Install new software > Add > Local
  6. Sélectionner le répertoire <path>/lustreeditor/trunk/lustre-parent/features/org.obeonetwork.dsl.lustre.update/target/repository
  7. Valider > Ok
  8. Sélectionner le Lustre Editor, installer.
  9. Redémarrer ObeoDesigner, l'éditeur Lustre est maintenant utilisable !

[Méthode 3] Utilisation du projet, sans l'installer en tant que plug-in Eclipse

Récupération des projets Eclipse

  1. Récupérer le projet lustre-parent du dépot (svn co https://cavale.enseeiht.fr/svn/lustreeditor)
  2. Sous Obeo, Import > General > Existing projects into workspace > Select root directory : Browse
  3. Sélectionner <path>/lustreeditor/trunk/lustre-parent/plugins
  4. Select All > Finish

Lancement de l'éditeur

  1. Faire (barre d'outil en haut) Run > Run Configurations
  2. Faire clic droit sur "Eclipse Application"
  3. Faire "new"
  4. Renommer si vous aviez d'autres Eclipse Application
  5. Dans Arguments/VM arguments écrire : -Xms512m -Xmx1024M -XX:MaxPermSize=512m
  6. Faire Run
  7. Un deuxième ObeoDesigner se lance, l'éditeur Lustre est maintenant utilisable via ce second Eclipse !

Utilisation de l'éditeur

  1. Créer un projet Modeling project
    .

    .

    .
  2. Ajouter des fichiers Lustre en utilisant la fonction Import dans Eclipse (autrement, le fichier ne sera pas reconnu)
    .

    .

    .

    .
  3. Faire clic droit sur le projet et sélectionner Viewpoints Selection
    .

    .
  4. Cocher Lustre Design
    .

    .
  5. Dérouler le fichier "Nomdufichier".lus dans l'Explorer Eclipse jusqu'a voir "Program"
    .
  6. Clic droit et faire New Representation -> new Program Diagram
    .

    .
  7. Entrer un nom et attendre que le diagramme s'affiche
    .

Notes

  1. Un projet exemple est disponible via : New > Others > Examples > Lustre Editor > Simple Lustre Program Example
  2. Le .aird correspondant à un diagramme peut être exporté en dépliant soit le fichier correspondant, soit representations.aird ; puis par clic droit sur le diagramme :
  3. ObeoDesigner prend en compte tous les fichiers .lus du projet courant, donc pour conserver des performances acceptables, ne mettez pas trop de fichiers dans un même projet.
  4. Si la pop-up bar de l'éditeur graphique vous dérange, vous pouvez l'enlever, modifier :
    Window > Preferences > Viewpoint > Viewpoint Diagram > Global settings > show popup bars

Annexes

Documentation

Projet long ENSEEIHT 2013

01.png (14.4 KB) Guillaume Babin, 03/06/2013 05:00 PM

02.png (7.62 KB) Guillaume Babin, 03/06/2013 05:00 PM

03.png (22.1 KB) Guillaume Babin, 03/06/2013 05:01 PM

04.png (16.9 KB) Guillaume Babin, 03/06/2013 05:01 PM

05.png (9.49 KB) Guillaume Babin, 03/06/2013 05:02 PM

06.png (17.7 KB) Guillaume Babin, 03/06/2013 05:02 PM

07.png (10.8 KB) Guillaume Babin, 03/06/2013 05:02 PM

08.png (18.5 KB) Guillaume Babin, 03/06/2013 05:02 PM

09.png (141 KB) Guillaume Babin, 03/06/2013 05:02 PM

10.png (21.9 KB) Guillaume Babin, 03/07/2013 12:51 AM