Project

General

Profile

Wiki » History » Version 84

Version 83 (Guillaume Babin, 03/07/2013 01:23 AM) → Version 84/94 (Guillaume Babin, 03/07/2013 06:13 PM)

h1. Editeur Lustre

h2. Installation de l'éditeur

h3. Prérequis

# Installer ObeoDesigner (http://www.obeodesigner.com/download)
# Installer le plug-in Xtext sous ObeoDesigner (http://www.eclipse.org/Xtext/download.html)

h3. [Méthode 1] Installation en tant que plug-in Eclipse à partir d'une archive déjà compilée

# Récupérer la dernière release sur https://cavale.enseeiht.fr/redmine/projects/lustreeditor/files
# Sous ObeoDesigner, Help > Install new software > Add > Archive
# Sélectionner l'archive téléchargée
# Valider > Ok
# Sélectionner le Lustre Editor, installer.
# Redémarrer ObeoDesigner, l'éditeur Lustre est maintenant utilisable !

h3. [Méthode 2] Installation en tant que plug-in Eclipse en compilant à partir des sources

# Installer @maven@ (version 3 ou supérieure) (@sudo apt-get install maven@ sous Ubuntu)
(configuration proxy : https://maven.apache.org/guides/mini/guide-proxies.html)
# Récupérer le projet lustre-parent du dépot (@svn co https://cavale.enseeiht.fr/svn/lustreeditor@)
# Se placer dans @<path>/lustreeditor/trunk/lustre-parent/@
# Exécuter @mvn clean verify@, attendre...
[@mvn -U clean verify@ peut régler des erreurs du type "@Failure to find ....... was cached in the local repository......@"]
# Sous ObeoDesigner, Help > Install new software > Add > Local
# Sélectionner le répertoire @<path>/lustreeditor/trunk/lustre-parent/features/org.obeonetwork.dsl.lustre.update/target/repository@
# Valider > Ok
# Sélectionner le Lustre Editor, installer.
# Redémarrer ObeoDesigner, l'éditeur Lustre est maintenant utilisable !

h3. [Méthode 3] Utilisation du projet, sans l'installer en tant que plug-in Eclipse

h4. Récupération des projets Eclipse

# Récupérer le projet lustre-parent du dépot (@svn co https://cavale.enseeiht.fr/svn/lustreeditor@)
# Sous Obeo, Import > General > Existing projects into workspace > Select root directory : Browse
# Sélectionner @<path>/lustreeditor/trunk/lustre-parent/plugins@
# Select All > Finish

h4. Lancement de l'éditeur

# Faire (barre d'outil en haut) Run > Run Configurations
# Faire clic droit sur "Eclipse Application"
# Faire "new"
# Renommer si vous aviez d'autres Eclipse Application
# Dans Arguments/VM arguments écrire : @-Xms512m -Xmx1024M -XX:MaxPermSize=512m@
# Faire Run
# Un deuxième ObeoDesigner se lance, l'éditeur Lustre est maintenant utilisable via ce second Eclipse !

h2. Utilisation de l'éditeur

# Créer un projet Modeling project
.
!https://cavale.enseeiht.fr/redmine/attachments/45/01.png!
.
!https://cavale.enseeiht.fr/redmine/attachments/46/02.png!
.
# Ajouter des fichiers Lustre *+en utilisant la fonction Import dans Eclipse+* (autrement, le fichier ne sera pas reconnu)
.
!https://cavale.enseeiht.fr/redmine/attachments/47/03.png!
.
!https://cavale.enseeiht.fr/redmine/attachments/48/04.png!
.
!https://cavale.enseeiht.fr/redmine/attachments/49/05.png!
.
# Faire clic droit sur le projet et sélectionner Viewpoints Selection
.
!https://cavale.enseeiht.fr/redmine/attachments/50/06.png!
.
# Cocher Lustre Design
.
!https://cavale.enseeiht.fr/redmine/attachments/51/07.png!
.
# Dérouler le fichier "Nomdufichier".lus dans l'Explorer Eclipse jusqu'a voir "Program"
.
# Clic droit et faire New Representation -> new Program Diagram
.
!https://cavale.enseeiht.fr/redmine/attachments/52/08.png!
.
# Entrer un nom et attendre que le diagramme s'affiche
.
!https://cavale.enseeiht.fr/redmine/attachments/53/09.png!

h4. Notes

# Un projet exemple est disponible via : New > Others > Examples > Lustre Editor > Simple Lustre Program Example
# Le @.aird@ correspondant à un diagramme peut être exporté en dépliant soit le fichier correspondant, soit @representations.aird@ ; puis par clic droit sur le diagramme :
!https://cavale.enseeiht.fr/redmine/attachments/55/10.png!
# ObeoDesigner prend en compte tous les fichiers @.lus@ du projet courant, donc pour conserver des performances acceptables, ne mettez pas trop de fichiers dans un même projet.
# Si la pop-up bar de l'éditeur graphique vous dérange, vous pouvez l'enlever, modifier :
Window > Preferences > Viewpoint > Viewpoint Diagram > Global settings > show popup bars




h2. Annexes

h3. Documentation

* [Architecture|architecture du logiciel]

h3.
Projet long ENSEEIHT 2013

* [[ProjetLongN72013|Travail préliminaire]]
* [[CdC|Dossier de Spécification Logicielle]]
* [[Grammaire|Grammaire Lustre]]