Project

General

Profile

Wiki » History » Version 84

Guillaume Babin, 03/07/2013 06:13 PM

1 78 Guillaume Babin
h1. Editeur Lustre
2 1 Pierre-Loïc Garoche
3 78 Guillaume Babin
h2. Installation de l'éditeur
4 29 Guillaume Babin
5 50 Guillaume Babin
h3. Prérequis
6 45 Guillaume Babin
7 54 Guillaume Babin
# Installer ObeoDesigner (http://www.obeodesigner.com/download)
8 53 Guillaume Babin
# Installer le plug-in Xtext sous ObeoDesigner (http://www.eclipse.org/Xtext/download.html)
9 1 Pierre-Loïc Garoche
10 76 Guillaume Babin
h3. [Méthode 1] Installation en tant que plug-in Eclipse à partir d'une archive déjà compilée
11 1 Pierre-Loïc Garoche
12 76 Guillaume Babin
# Récupérer la dernière release sur https://cavale.enseeiht.fr/redmine/projects/lustreeditor/files
13 77 Guillaume Babin
# Sous ObeoDesigner, Help > Install new software > Add > Archive
14 77 Guillaume Babin
# Sélectionner l'archive téléchargée
15 76 Guillaume Babin
# Valider > Ok
16 76 Guillaume Babin
# Sélectionner le Lustre Editor, installer.
17 76 Guillaume Babin
# Redémarrer ObeoDesigner, l'éditeur Lustre est maintenant utilisable !
18 69 Guillaume Babin
19 76 Guillaume Babin
h3. [Méthode 2] Installation en tant que plug-in Eclipse en compilant à partir des sources
20 51 Guillaume Babin
21 1 Pierre-Loïc Garoche
# Installer @maven@ (version 3 ou supérieure) (@sudo apt-get install maven@ sous Ubuntu)
22 50 Guillaume Babin
   (configuration proxy : https://maven.apache.org/guides/mini/guide-proxies.html)
23 49 Guillaume Babin
# Récupérer le projet lustre-parent du dépot (@svn co https://cavale.enseeiht.fr/svn/lustreeditor@)
24 67 Guillaume Babin
# Se placer dans @<path>/lustreeditor/trunk/lustre-parent/@
25 67 Guillaume Babin
# Exécuter @mvn clean verify@, attendre...
26 1 Pierre-Loïc Garoche
   [@mvn -U clean verify@ peut régler des erreurs du type "@Failure to find ....... was cached in the local repository......@"]
27 76 Guillaume Babin
# Sous ObeoDesigner, Help > Install new software > Add > Local
28 58 Guillaume Babin
# Sélectionner le répertoire @<path>/lustreeditor/trunk/lustre-parent/features/org.obeonetwork.dsl.lustre.update/target/repository@
29 1 Pierre-Loïc Garoche
# Valider > Ok
30 59 Guillaume Babin
# Sélectionner le Lustre Editor, installer.
31 59 Guillaume Babin
# Redémarrer ObeoDesigner, l'éditeur Lustre est maintenant utilisable !
32 35 Guillaume Babin
33 76 Guillaume Babin
h3. [Méthode 3] Utilisation du projet, sans l'installer en tant que plug-in Eclipse
34 35 Guillaume Babin
35 61 Guillaume Babin
h4. Récupération des projets Eclipse
36 61 Guillaume Babin
37 49 Guillaume Babin
# Récupérer le projet lustre-parent du dépot (@svn co https://cavale.enseeiht.fr/svn/lustreeditor@)
38 43 Romain BOBO
# Sous Obeo, Import > General > Existing projects into workspace > Select root directory : Browse
39 56 Guillaume Babin
# Sélectionner @<path>/lustreeditor/trunk/lustre-parent/plugins@
40 35 Guillaume Babin
# Select All > Finish
41 61 Guillaume Babin
42 61 Guillaume Babin
h4. Lancement de l'éditeur
43 60 Guillaume Babin
44 60 Guillaume Babin
# Faire (barre d'outil en haut) Run > Run Configurations
45 60 Guillaume Babin
# Faire clic droit sur "Eclipse Application"
46 60 Guillaume Babin
# Faire "new"
47 60 Guillaume Babin
# Renommer si vous aviez d'autres Eclipse Application
48 63 Guillaume Babin
# Dans Arguments/VM arguments écrire : @-Xms512m -Xmx1024M -XX:MaxPermSize=512m@
49 60 Guillaume Babin
# Faire Run
50 57 Guillaume Babin
# Un deuxième ObeoDesigner se lance, l'éditeur Lustre est maintenant utilisable via ce second Eclipse !
51 30 Romain BOBO
52 78 Guillaume Babin
h2. Utilisation de l'éditeur
53 41 Guillaume Babin
54 72 Guillaume Babin
# Créer un projet Modeling project
55 83 Guillaume Babin
.
56 1 Pierre-Loïc Garoche
!https://cavale.enseeiht.fr/redmine/attachments/45/01.png!
57 83 Guillaume Babin
.
58 1 Pierre-Loïc Garoche
!https://cavale.enseeiht.fr/redmine/attachments/46/02.png!
59 83 Guillaume Babin
.
60 1 Pierre-Loïc Garoche
# Ajouter des fichiers Lustre *+en utilisant la fonction Import dans Eclipse+* (autrement, le fichier ne sera pas reconnu)
61 83 Guillaume Babin
.
62 1 Pierre-Loïc Garoche
!https://cavale.enseeiht.fr/redmine/attachments/47/03.png!
63 83 Guillaume Babin
.
64 1 Pierre-Loïc Garoche
!https://cavale.enseeiht.fr/redmine/attachments/48/04.png!
65 83 Guillaume Babin
.
66 1 Pierre-Loïc Garoche
!https://cavale.enseeiht.fr/redmine/attachments/49/05.png!
67 83 Guillaume Babin
.
68 1 Pierre-Loïc Garoche
# Faire clic droit sur le projet et sélectionner Viewpoints Selection
69 83 Guillaume Babin
.
70 1 Pierre-Loïc Garoche
!https://cavale.enseeiht.fr/redmine/attachments/50/06.png!
71 83 Guillaume Babin
.
72 1 Pierre-Loïc Garoche
# Cocher Lustre Design
73 83 Guillaume Babin
.
74 1 Pierre-Loïc Garoche
!https://cavale.enseeiht.fr/redmine/attachments/51/07.png!
75 83 Guillaume Babin
.
76 1 Pierre-Loïc Garoche
# Dérouler le fichier "Nomdufichier".lus dans l'Explorer Eclipse jusqu'a voir "Program"
77 83 Guillaume Babin
.
78 1 Pierre-Loïc Garoche
# Clic droit et faire New Representation -> new Program Diagram
79 83 Guillaume Babin
.
80 1 Pierre-Loïc Garoche
!https://cavale.enseeiht.fr/redmine/attachments/52/08.png!
81 83 Guillaume Babin
.
82 71 Guillaume Babin
# Entrer un nom et attendre que le diagramme s'affiche
83 83 Guillaume Babin
.
84 71 Guillaume Babin
!https://cavale.enseeiht.fr/redmine/attachments/53/09.png!
85 71 Guillaume Babin
86 41 Guillaume Babin
87 65 Guillaume Babin
h4. Notes
88 65 Guillaume Babin
89 75 Guillaume Babin
# Un projet exemple est disponible via : New > Others > Examples > Lustre Editor > Simple Lustre Program Example
90 81 Guillaume Babin
# Le @.aird@ correspondant à un diagramme peut être exporté en dépliant soit le fichier correspondant, soit @representations.aird@ ; puis par clic droit sur le diagramme :
91 79 Guillaume Babin
!https://cavale.enseeiht.fr/redmine/attachments/55/10.png! 
92 65 Guillaume Babin
# ObeoDesigner prend en compte tous les fichiers @.lus@ du projet courant, donc pour conserver des performances acceptables, ne mettez pas trop de fichiers dans un même projet.
93 65 Guillaume Babin
# Si la pop-up bar de l'éditeur graphique vous dérange, vous pouvez l'enlever, modifier :
94 55 Guillaume Babin
Window > Preferences > Viewpoint > Viewpoint Diagram > Global settings > show popup bars
95 44 Jason CROMBEZ
        
96 84 Guillaume Babin
h2. Annexes
97 1 Pierre-Loïc Garoche
98 84 Guillaume Babin
h3. Documentation
99 84 Guillaume Babin
100 84 Guillaume Babin
* [Architecture|architecture du logiciel]
101 84 Guillaume Babin
102 84 Guillaume Babin
h3. Projet long ENSEEIHT 2013
103 26 Guillaume Babin
104 26 Guillaume Babin
* [[ProjetLongN72013|Travail préliminaire]]
105 28 Guillaume Babin
* [[CdC|Dossier de Spécification Logicielle]]
106 27 Guillaume Babin
* [[Grammaire|Grammaire Lustre]]