Project

General

Profile

Edit Actions

Bug #58

closed

int to long long int

Added by Hamza Bourbouh over 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Urgent
Category:
Bug
Start date:
12/07/2017
Due date:
% Done:

0%

Estimated time:

Description

In C code generated from lustre, int is kept as int in C. Big constants in Lustre raises some range exception.
Changing int to long long int may solve the problem.


Files

datatypeconversion13_PP.lus (994 Bytes) datatypeconversion13_PP.lus Hamza Bourbouh, 04/07/2018 04:05 AM

Updated by Hamza Bourbouh about 4 years ago

I added a test file.
The issue is coming when executing the binary:
./datatypeconversion13_PP_datatypeconversion13_PP
In20_1 (double) ? 1
Floating point exception: 8

Updated by Pierre-Loïc Garoche about 4 years ago

  • Status changed from New to Closed

Already supported by option -real or -int

Edit Actions

Also available in: Atom PDF